ダーツ成長日記。試行錯誤の成果が出るからやめられない♪
by wakaspec

ダーツはなでしこだ!
職場の人に『なでしこ』という、
日本語でプログラムを書けるツールを紹介してもらったので試してみることに。
公式サイトはここ (http://nadesi.com/)
相当昔に試したことのある、
日本語で~なツールはネタ程度だった記憶がありますが、
「今回のはどうなんだ?」と不安を感じつつ数十分。

感想は、
Windows&スクリプト程度で済む処理なら
標準C/C++よりよっぽど楽で強力だぁ~と感じました。
実行形式のファイルも作れるしね。(DLLの配布も必要だけど。)

と、もっと遊びたいけど、仕事中なのでこの辺で。

Moreって機能があったので、長ったらしかったソースを隠蔽。



実験結果はこれ↓。
公式サイトから本体DL→解凍→起動、エディタに下のを貼り付けて実行。

★-------------------------------------------↓ここから
マイダーツはSidewinder。
マイダーツウェイトは18 #グラム(g)
「あなたのダーツは何グラムですか?」と尋ね、ユアダーツウェイトに代入。
「わたしのダーツは{マイダーツ}で、
重さは{マイダーツウェイト}gです。」と表示し、
「あなたのダーツの重さはは{ユアダーツウェイト}gですね。」と表示。
もしマイダーツウェイトとユアダーツウェイトが等しいならば「一緒だね!」と言い、
違えば「一緒じゃないね。残念!」と言う。

「------------------------------------------------」を表示。
"http://bullspec.exblog.jp/index.xml"のHTTPデータ取得し、bullspecに代入。
bullspecをUTF8N_SJIS変換し、bullspec_sjisに代入。
##bullspecからHTMLリンク抽出し、bullspecに代入。
bullspec_sjisからtitleの階層タグ切り出しからタグ削除し、タイトルに代入。
タイトルを改行で区切り、タイトルリストに代入。
「取得したblogタイトルは、」を表示。
今の文字色をデフォルト色に代入。
文字色は青色
「{タイトル[0]}」を表示。
文字色はデフォルト色
「最近の記事タイトル一覧は、」を表示。
文字色に112233を代入。
2からタイトルリストの配列要素数-1まで繰り返す
 「{タイトルリスト[それ]}」を表示
文字色はデフォルト色にする

「------------------------------------------------」を表示。
bullspecを"{テンポラリフォルダ}\bullspec.xml"に保存
「取得したHTTPデータを
"{テンポラリフォルダ}\bullspec.xml"
に保存しました。
起動します。」と言う。

1秒待つ。

線引き
線色リストは「
黒線
赤線
青線
緑線

線横開始は基本X。
線縦開始は基本Y+20。
デフォルト線色は線色。
デフォルト塗り色は塗り色。
線色リストのリスト選択を選択線色に代入。
もし選択線色が赤線ならば線色に赤色を代入。
違えば、もし選択線色が青線ならば線色に青色を代入。
違えば、もし選択線色が緑線ならば線色に緑色を代入。
線太さは2。線スタイルは点線。
線横開始,線縦開始から線横開始+200,線縦開始へ線。
1秒待つ。
線色は222222。
塗り色は黒色。
線横開始+200-10,線縦開始-10から線横開始+200+10,線縦開始+10へ円。
1秒待つ。
線色は赤色。
塗り色は赤色。
線横開始+200-4,線縦開始-4から線横開始+200+4,線縦開始+4へ円。
1秒待つ。
色選択。
線色はそれ。線スタイルは実線。
線(線横開始,線縦開始+40,線横開始+200,線縦開始)
線横開始+200+20,線縦開始へ"BULLSPEC!"を文字描画
線色はデフォルト線色。
塗り色はデフォルト塗り色。
1秒待つ
"{テンポラリフォルダ}\bullspec.xml"を起動する。
★-------------------------------------------↑ここまで
[PR]
by wakaspec | 2005-01-17 15:00 | ダーツあれこれ

<< 集中力をひきだせ~      理論派 >>
BULLすぺっくバナー
バナー詳細はここ。
リンクはご自由に
S M T W T F S
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30
カテゴリ
以前の記事
メモ帳
★管理人info
わかすぺっく
27♂
DMC Sidewinder
吉祥寺、渋谷、池袋
≪e-mail≫

★23区まとはずれ
XOOPS (PC用)
携帯用案内

★Liveスコア
- 2005/10/21 -
RATING: 10.39
FLIGHT: A

----- STATS -----
01 : 78.95 pts
Cricket : 3.07 mark
Count-Up : 585.6 pts

----- HI SCORE -----
COUNT UP
  908 pts
CRICKET COUNT-UP
  604 pts
ROTATION
  24 pts
EAGLE'S EYE
  550
HALF-IT
  625 pts
ARRANGE MANIA
  21 pts
ROUND THE CLOCK
  43 pts

★リンク
DARTSLIVE
バネバグース
Pierrot Cafe
ダーツ料金表
DMC Japan
Tripleight
9darts.TV

★blog内リンク
(自分用)
Custom Card (準備)1,2
タイミング台詞
BULL確率考察
珍事
ブリッスル設置
勉強
お気に入りブログ
最新のトラックバック
sharp microw..
from sharp microwav..
online samur..
from online samurai..
authorize.ne..
from authorize.net ..
patio cover
from patio cover
aldrich cata..
from aldrich catalo..
ライフログ
検索
その他のジャンル
ファン
記事ランキング
ブログジャンル
画像一覧